Cannot send outgoing email. System .ArgumentException. Parameter address cannot be an empty string


Hi,



Finally got around to installing the new KB v2.0 and cannot get outgoing email to work. I've tried it with my local SMTP server & with an authenticated server. Both are verified to work perfectly.

Turning on the debug option gives me the following message.

Runing 2.0.5

Can anyone help?



Thanks

Iain



The application encountered an unexpected problem.

Unexpected Problem Occurred!



This error has been logged. If this problem persists please contact the web master.



More Information...



Detailed error information follows:



Date and Time: 5/15/2009 12:32:59 AM

Machine Name: S15269794

Process User: NT AUTHORITY\NETWORK SERVICE

Remote User: abc@abc.co.uk

Remote Address: x.x.x.x

Remote Host: x.x.x.x

URL: https://kb.lccs.co.uk/Admin/AdminEditMemberDetails1-2.aspx



NET Runtime version: 2.0.50727.3082

Application Domain: /LM/W3SVC/902188707/Root-1-128868171731562500

Assembly Codebase: C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

Assembly Full Name: System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

Assembly Version: 2.0.0.0

Assembly Build Date: 5/15/2009 12:15:34 AM



Exception Type: System.ArgumentException

Exception Message: The parameter 'address' cannot be an empty string.

Parameter name: address

Exception Source: System

Exception Target Site: .ctor



---- Stack Trace ----

System.Net.Mail.MailAddress..ctor(address As String, displayName As String, displayNameEncoding As Encoding)

(unknown file): N 1098157

System.Net.Mail.MailAddress..ctor(address As String)

(unknown file): N 00008

InstantASP.Common.Mail.Queue.SendQueuedMail()

(unknown file): N 01287


Hi Iain, this isnt a known issue, can I ask you to submit a support ticket with this report pasted into it so that we can look into this for you.

Kindest Regards,

James Trott

I've already sent an email to support@instantasp.co.uk a couple of days ago but have got no response to that at all. I've now submitted a ticket.



I've tried today installing a totally new/fresh copy of the KB on a different machine with a new blank database and get exactly the same result. So either there is a problem with 2.0.5 or I'm missing something obvious here?



I have set the SMTP Server Address in the web interface as per instructions for getting email to work.

This problem can be sorted out by downloading the latest version of 2.0.5.
GO

Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....







InstantASP Forums


Search