Cannot see WYSIWYG Editor within InstantForum 2010


InstantForum Problem
The implementation of our new InstantASPForum2010.3 is going well.

The WYSIWYG editor is not available for any user regardless of the permission group they are in. We've been changing the permissions settings on various groups and searching the forum and are stuck at the moment.

We've tested in IE8 and Firefox

Any suggestions?

Many thanks,

Ernie
InstantForum Problem

Could it possibly be this? - https://community.instantasp.co.uk/15619/JS-Error---Content-Editor?Keywords=WYSIWYG%20Editor%20%20Available

Hi Ernie,

Hope your very well. Are you running InstantForum.NET under .NET 4.0?

If so could you try the attributes within the <pages/> element of your web.config...

<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>


Please let me know if this helps,

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png

Hi Ryan,

Your suggested solution fixed the problem.  Thank you very much.

Ernie

Ryan,

You did solve my initial problem, but I have stepped right into another. The WYSIWYG is available and functions just fine until I submit the post. Then I get the following error.

Webpage error details 

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; MS-RTC LM 8; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; MS-RTC EA 2)
Timestamp: Mon, 9 Aug 2010 20:14:28 UTC

Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 500
Line: 868
Char: 13
Code: 0
URI: https://192.168.0.203:5043/InstantForum2010/ScriptResource.axd?d=5NOA2HEiN4PUVir8OQ2E7CtiukQ3o3cJQ


The error only appears in IE. In firefox, the page does not throw and error, but it doesn't submit the post either. It just waits as if the submit button was not pushed. I'm guessing we're getting the same error there.

We started crawling the forums and KB for information, but have not been able to find an exact match for this issue.

Thank you for your continued assistance. You've been most helpful.

Ernie

Hi Ernie,

Thank you for your response. I'm pleased to hear my previous suggestion helped. Sorry to hear of the new problem.

Unfortunately the error message does not offer to much information to help us debug here and offer some solid suggestions.

One thing to check. I would ensure the various database columns within your InstantForum_Topics table that do not allow NULLs all have a default value. We've seen an issue in some cases with constraints being removed from the database during upgrades.

Also would you be able to open up the site to allow us to access this externally. We can perform further debugging here to offer more accurate suggestions on to help resolve this.

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png

Hi Ryan,

I am interested in taking you up on your offer to look at the site directly.  Presently it's only available on our internal web development server.  We might be able to post a copy on our external live server, or work out remote access if we can come up with a time that works for both of us.

Before proceeding down that road I have more information.  I continued to experiment after reading your last post and tried to add some rich text from the admin control panel, while editing a forum.  It failed, but gave me a much more descriptive error message.

A potentially dangerous Request.Form value was detected from the client (ctl00$ctlContentPlaceHolder$ctl00$ctlAdminViewForum$ctlPanelBar1$txtForumDescription="Read this fo...")


My mind immediately jumped to page validation.  I'd checked the web config file and validateRequest="false"  was in the <pages> tag.    Our web.config pages section reads like this:

<pages buffer="true" enableViewState="false" enableViewStateMac="false" validateRequest="false" controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">    
            <controls>
                <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>           
</controls>
</pages>


It seems to me that ASP.NET is complaining about what's being submitted.  I'm going to dig around and see if there is something new in IIS7.5 that I am overlooking, or perhaps there is already a post about page validation on your forums. 

I thought this was worth mentioning, before having you access our installation remotely.

Thanks again for the continued communication and support.

Ernie

 I fixed the problemand can post through WYSIWYG. 

I needed to add: <httpRuntimerequestValidationMode="2.0"/> to my web.config file

I googled, “A potentially dangerous Request.Form value wasdetected from the client iis 7”, looking for something that might have changedin IIS 7.5 or .net4.   

I found a posts indicatingsomething had changed between 3.5 and 4.0, people were getting thus under 4.0and not under 3.5 even when using the controlRenderingCompatibilityVersion="3.5"attribute in the pages tag of the web.config file.   

This setof posts: https://stackoverflow.com/questions/2473972/a-potentially-dangerous-request-form-value-was-detected-but-validateinputfalseprovided the solution and had a link to a Microsoft whitepaper https://www.asp.net/learn/whitepapers/aspnet4/breaking-changes#0.1__Toc256770147The white paper describes changes that have been made for the .NET Frameworkversion 4 release that can potentially affect applications that were createdusing earlier releases, including the ASP.NET 4 Beta 1 and Beta 2 releases.   The relevant section reads as follows:

ASP.NET Request Validation

The request validation feature in ASP.NETprovides a certain level of default protection against cross-site scripting(XSS) attacks. In previous versions of ASP.NET, request validation was enabledby default. However, it applied only to ASP.NET pages (.aspx files and theirclass files) and only when those pages were executing.

In ASP.NET 4, by default, request validation isenabled for all requests, because it is enabled before the BeginRequestphase of an HTTP request. As a result, request validation applies to requestsfor all ASP.NET resources, not just .aspx page requests. This includes requestssuch as Web service calls and custom HTTP handlers. Request validation is alsoactive when custom HTTP modules are reading the contents of an HTTP request.

As a result, request validation errors mightnow occur for requests that previously did not trigger errors. To revert to thebehavior of the ASP.NET 2.0 request validation feature, add the followingsetting in the Web.config file:

<httpRuntime requestValidationMode="2.0" />
However, we recommend that you analyze anyrequest validation errors to determine whether existing handlers, modules, orother custom code accesses potentially unsafe HTTP inputs that could be XSSattack vectors.

 I also realized Iposted in the InstantKB section, not the InstantForum section.  Sorry for the error.

Ernie

Ahh good old request validation.

Thank you for posting this very helpful information Ernie. I'm sure others will find this helpful.

We do set requestValidation to false within our web.config however from your post it's clear we need new tags for .NET 4.0.

We'll be looking to update the downloads to ensure this works out the box in future updates.

Thanks again Ernie for taking the time to post :)

UPDATE: This issue has since been resolved so this topic has been closed. If you encounter similar problems or we can assist further don't hesitate to start a new topic here within our forum.

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png
GO

Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....







InstantASP Forums


Search