InstantForum 2012 Not Sending Email?l


InstantForum Problem
Have upgraded to 2012. Most stuff seems to be working fine, except mail. I cannot seem to get IF 2012 sending mail.

We have the site on our own server, this is running other ASP.NET sites that are sending mail fine. I've enabled mails in IF's settings, but it doesn't seem to reach the SMTP server. The previous versions we seemed to have no problems with, and I don't see anything different here.

I've done the recommended mail test of changing a username and watching the mail appear in the outgoing database queue. It shows up there ok. But after three failed attempts, it disappears. But no SMTP errors are logged. I've also set the <add key="InstantASP_ExceptionLogMethod" value="ToFile"/> tag in the web config, and ensured the IIS appuser for this site has full control (to write files) but nothing gets added to the exceptions config log.

I don't think it's an SMTP problem, as no exception is generated, and nothing is logged. It just doesn't look like the mail send from IF even hits the SMTP.

I'm assuming IF 2012 is sending mail elsewhere, so I'm tearing my hair out trying to figure this out. If I could get it to at least hit SMTP, even if it generates errors, I'd have something to work with. But it just doesn't get that far. IF is saying it's sending mail, but my SMTP service isn't seeing anything. All the other sites on the server are sending mail fine, so I'm pretty sure the SMTP is running fine, is accessible and so on.


--
http://www.kartris.com
Free ASP.NET ecommerce, GPL license, responsive interface, unlimited languages and currencies, supports 1,000,000+ SKUs

Tags

InstantForum Problem

Hi flackster,

I hope your very well. Thank you for your post. I'm sorry to hear of the email trouble. Can you try the following...

First thing to check. If your not using SSL for SMTP ensure the following setting in the forum web.config is false...

<add key="InstantASP_EnableSSLForSMTPServer" value="false" />


If your sure this is correct please try the following...

1. Open your InstantForum web.config file and set the following 2 values to true....

<add key="InstantASP_AutoFlushMailQueue" value="true" /> 
<add key="InstantASP_EnableSMTPDebug" value="true"/>


2. Login as an administrator and visit the Admin CP. Click Manage Members and locate your user account. Edit your user account and locate the "Edit Username" link. Click this and you'll have the ability to enter a new username for your account. We don't really want to update your username however this is a good way to test emails are being sent correctly as one will be generated and sent to you whenever you update your username. For now just enter the same username as you already have. Ensure the send email option is checked and click submit.

If this is a SMTP configuration issue and you have customErrors disabled within the web.config file you should now see the yellow screen of death with the exception message and full .NET stack trace. Please post that here if so or email me directly.

If you don't receive any error and emails are still not being received please email me on ryan@instantasp.co.uk. I would be happy to set-up a goto meeting and connect to troubleshoot further, [/code]

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png
Tags


I noticed there was a 4.0 web config in the root. I was using the default one, but running on 4.0. I thought this might be the problem but it wasn't. I flipped in the 4.0 web config, made the required changes and same problem.

I followed the process you outlined. But the system gives me the 'success' message and says mail is sent. But it still isn't.

So I decided to change the mailserver IP address to 0.0.0.0, just to ensure I generate an error. And it doesn't... it gives me a 'success' message.

That indicates to me it simply doesn't matter what SMTP settings i have, because it's not hitting SMTP at all. It's just saying that mail is sent, but it isn't.

Is it possible you can sign up and I can make you an admin so you can check my settings in the back end... I **definitely** have mail enabled there.

--
http://www.kartris.com
Free ASP.NET ecommerce, GPL license, responsive interface, unlimited languages and currencies, supports 1,000,000+ SKUs


Sure - Please send me your login details to ryan@instantasp.co.uk. I look forward to hearing from you and assisting further,

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png

It seems to be working now curiously... not sure why, I didn't change anything since a few days ago. Not sure if something kicked in after the app pool recycled or maybe a server restart. But all appears well now.

Like the new version btw. There still seems to be the issue with the upgrade process from a 3 or 4 year old version requiring default values to be added manually to the posts table, but I had the previous ticket regarding this so it wasn't a problem for me.

--
http://www.kartris.com
Free ASP.NET ecommerce, GPL license, responsive interface, unlimited languages and currencies, supports 1,000,000+ SKUs


Hi flackster, I'm pleased to hear this resolved itself. Of course if you experience any email issues again please don't hesitate to respond here or email me directly. We are aware of some default constraints / values being lost when you upgrade from earlier versions of InstantForum (4.1.4). Unfortunately for now the easiest way to resolve this is the add the half a dozen or so default values back into the database. Once these have been added as shown in my ticket the forum should work fine at run time. If you do encounter any issues of course please let me know I'll certainly help,

Thanks for your kind comments flackster.

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png

Just had to implement the item 1 fix in the 2013-1 version and that has fixed the issue again :)

Ant

Just to add the email send out for password/registration and such was working fine. It was when trying to send bulk messages is where it failed it would only send the first and the rest just disappeared!!

All good now :)

Ant
GO

Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....







InstantASP Forums


Search