Unable to upload image to InstantKB 2014


My issue is related to images. If I try to upload 'Media' that appears to work, however when I'm editing an article and click the "Image Manager" icon to the side of the text editor, the window for images opens, but shows no folder information, no images, and the upload button is disabled.

What could be wrong with my install?

Thank you,
Marc
https://community.instantasp.co.uk/uploads/images/6d5ef3c2-a6d9-4e79-8870-2a09.png

https://community.instantasp.co.uk/uploads/images/bd38755d-ee49-45e7-810d-787c.png

InstantKB Problem

Hi Marc,

Happy new year. Thank you for your post. I'm sorry to hear of the trouble and for my delay responding here.  

First I would suggest checking the administrator settings. Visit the Admin CP and hover over the gear icon on the left. Click Settings. Click Knowledgebase Settings. Locate the "Uploads Folder" section. These should read by default...

Image Upload Directory: Uploads/Images
Media Upload Directory: Uploads/Media
Member Level & Photo Upload Directory: Uploads/Photos

If you see an issue with the "Image Upload Directory" path this may be the issue,. 

If you don't see any issues here I would ensure the windows account under which your InstantKB application pool runs within IIS has read permissions on the "Uploads" Ifolder & all child objects. The Uploads folder by default can be found within the root of your InstantKB installation. 

Load Balanced?

Have you configured InstantKB to work in a load balanced environment by hard coding a central UNC  path to point to where the "Uploads" folder cam be found within the web.config file. For example <add key="InstantASP_UploadPath" value="\\fileserver\SharedUploads\" /> If so you would need to ensure you add a virtual directory within each IIS instance for InstantKB called Uploads that points to the Uploads folder within your central UNC share. As you are saving files to a network share you would also need to enable impersonation within the web.config and either use a domain account or create identical local accounts on each web server and your central file server. You would then need to ensure the account you use for impersonation within the web.config has read, write and modify access to the Uploads folder within your network share.  

Please let me know if any of these suggestions help Marc. Don't hesitate tor respond if the problem continues. 


http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png
GO

Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....







InstantASP Forums


Search