Unable to Upload Images - InstantForum 2013-2


InstantForum Problem
Greetings,

We have recently decided to make a push for our clients to use our forum more often (InstantForum 2013-2 Final).  I have been put in charge of posting new and relevant information so it will be beneficial to our customers.  I have encountered an odd issue when inserting a photo (tried PNG and BMP) into a forum post. After I select a file from the browser and select open, it brings up the insert screen.  The insert screen button says "please wait..." and the center of the screen, that previously said "Select File", reloads the main forum page inside of the small area. 

I was unable to find anything posted on here previously, so any help or suggestions would be greatly appreciated. 

Thank you,

Parrish Foster
Quality Assurance Specialist
OrionNet Systems, LLC

Edited
4 Years Ago by Parrish_F
InstantForum Problem

Hi Parrish,

Thank you for your post and welcome to the forum. I'm sorry for my delay responding. 

This is most certainly a permissions issue. This would suggest that the windows account under which your InstantForum IIS application pool runs does not have "modify" and "write" permissions to the "Uploads" folder within the root of InstantForum. The Uploads folder is used to store images you upload from your local hard-drive. 

To resolve this please follow the steps in the article linked below. 
https://docs.instantasp.co.uk/Docs/Configure-InstantForum-File-Permissions

If the problem persists of course please don't hesitate to respond here or email me directly on ryan@instantasp.co.uk.

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png

Ryan,

Below are the items we tried to figure out permission issue on Forum. 

1.On the server, we created one new folder "Uploads" under C:\IIS\ThinkHealthForum. (because the folder did not exist)
2.Then I open IIS manager and found the identifier for ThinkHealth Forum application Pool is "OrionetNet\onsaspuser"
3.Go back to folder C:\IIS\ThinkHealthForum, right click "Uploads" folder and open property screen. Under security table, set up all right for all windows account users in list.
4.Did the same thing for "Skin" folder to set up full permission.
5.Open the the browser load the Forum and log in.
7.Then I chose one topic and try to insert one image. But it keeps showing "Please wait" and cannot upload image.

Because that “Uploads” folder is created manually by us, so we thought the program could create it automatically after user upload one image. But I did not find that folder in Forum project code.
We need to confirm if “Uploads” folder is really in root folder on version 2013 or it is in another folder, as the link appears to be for version 2015.

Are we missing something obvious? We tried and tried but could not get it to work.  Our version of the forum does not seem to have this folder


Hi Parrish,

Thank you for your detailed response. I hope the article was helpful. It looks like you've certainly followed the steps correctly. The "Uploads" folder should always exist within the root of your InstantForum or InstantKB installation.  This folder has been present in all InstantForum & InstantKB downloads for several years and it should be present in your 2013 download.

We use this folder to store all user uploaded images embedded within forum posts. 

To help I've included a image below which shows all the default folders which may help you compare. This is from InstantForum 2015....

https://community.instantasp.co.uk/uploads/images/c2a547f6-e799-41f8-ba00-b9c0.png


It is possible to customize the default location uploads are stored so if this was customized during the original installation this may explain why you don't see an "Uploads" folder. You can set a relative path from your application root to the "Uploads" folder from within the InstantForum Admin CP > Forum Settings page or you can set a hard coded full physical path or UNC path to the "Uploads" folder within the InstantASP_UploadPath application setting within the web.config file for either InstantForum or InstantKB. 

We don't check to ensure the folder you specify for uploads already exists. You will need to ensure the folder exists first and has the correct "write" & "modify" permissions for the windows account under which your application pool runs. Checking this folder already exists is a good idea and has already been added for the next update expected soon. 

I hope this helps you troubleshoot further Parrish and understand the "Uploads" folder. If I can assist further with any additional questions of course please don't hesitate to respond, 

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png

Hi Ryan,

I am one developer of OrionNet Systems. We fixed that upload image issue by adding one Uploads folder with all sub-folders manually on our server and setting up full permissions on windows account like what you mentioned. I am not pretty sure why the Uploads folder disappear after publishing the whole project by visual studio, but the production version works well now after we add folders manually. 

Thank you very much for your detailed answers and time.

Best Regards, 
Yufeng Guo

Hi Yufeng,

Very nice to hear from you. Thank you for your post. I'm pleased to hear my answers helped. Of course if I can assist with any further questions or problems don't hesitate to post here within our forums. Best wishes for now, 

http://www.instantasp.co.uk/images/line.gif
Kindest Regards,

Ryan Healey



ryan@instantasp.co.uk
www.instantasp.co.uk
Blog | Community | Docs

http://www.instantasp.co.uk/core/assets/images/email/facebook.png http://www.instantasp.co.uk/core/assets/images/email/twitter.png http://www.instantasp.co.uk/core/assets/images/email/google.png http://www.instantasp.co.uk/core/assets/images/email/linkedin.png
GO

Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....







InstantASP Forums


Search